Upload File Prefix overwriting local upload directory



  • By default, Wordpress stores media uploads to:
    [SITE_ROOT]/wp-content/uploads/yyyy/mm/...

    However, if you specified an Upload File Prefix setting, that gets ADDED to the local storage as well, result in local uploads with the following structure:
    [SITE_ROOT]/wp-content/uploads/PREFIX/yyyy/mm...

    If you deactivate Media Cloud, all images upload since that prefix was specified are now broken since Wordpress is looking for /wp-content/uploads/yyyy/mm...

    The description of this field states, "This will prepend a prefix to any file uploaded to cloud storage." Is this just a bug or was this the intended behavior?



  • @iTim314

    That's the intended behavior. It would be a real big mess if local and cloud paths didn't map.

    Also, there's no reason your images would be broken after deactivation UNLESS you are using Imgix or Dynamic Images because thumbnails won't be generated on upload if either of those are enabled. The other way images could be broken after deactivation is if you have "Delete on Upload" enabled, but that isn't enabled by default.

    https://www.loom.com/share/ec1349404827420d931b96d81467b0bf



  • I've come to the conclusion that I just need to create a dedicated bucket just for these uploads to go to and forget about prefixes.

    Is there a nuclear/erase option to erase all traces of Media Cloud? Now the issue is that even if I uninstall the plugin and remove mcloud% from the wp_options table, it won't attempt to re-upload existing files to the new bucket even if I deselect the Skip option. It still thinks images are uploaded. However, it's still trying to serve it from the new bucket without uploading, and all my images are blank.

    So how I can I do a complete reset of this plugin?



  • @iTim314

    There is a command line tool you can run:

    wp mediacloud unlink

    It doesn't download images, it just scrubs the metadata.

    https://mediacloud.press/documentation/advanced/command-line

    Towards the bottom of the page.



  • Thank you for your patience with me, this worked.



  • @iTim314

    No worries, that's what I'm here for!

    I'll be the first to admit it's not the easiest plugin to configure, but I promise once you do it becomes pretty transparent to your use of WordPress.



  • Honestly it's not that hard to use, I think my problem is me simultaneously learning how AWS/S3 works. I have certain mental expectations on how things are supposed to work and reality doesn't reflect that. That's on me, not you.

    Keep up the great work. 🙂


Log in to reply