Blank Screen on Plugin Settings and Features



  • So installing the Media Cloud plugin was successful, however when trying to access the Features or Setting tabs we are presented with a blank screen. All other tabs bring up the intended content.

    Have already tried removing the plugin and reinstalling without success. Only have one other plugin installed, deactivated it, to no avail, so we are at loss as to what is causing the issue. We have the plugin installed on another WP instance without issue.

    Any ideas?!
    blankScreen.PNG



  • @thisispa

    Media Cloud uses Laravel's view system (Blade) to render settings pages. Part of that system is a step where it generates intermediate files before displaying the view. It stores those intermediate files in your content directory in a folder called mcloud-views.

    You should check your wp-content directory and see if that folder exists. If it doesn't, then permissions on your wp-content directory are preventing it from being created. Create the directory and make sure the permissions are the same as your upload directory.

    If that doesn't help, there must be another error happening. If possible, you'll need to have PHP error logging configured at the PHP level. Once you've confirmed that it is, go back to the settings page and then check the log for errors. Please send me any errors you find.

    Thanks!



  • Created the mcloud-views directory in wp-content and double checked that permissions were set to allow writing - no luck. Error on setting page as follows;

    Warning: file_put_contents(): https:// wrapper is disabled in the server configuration by allow_url_fopen=0 in /home/thisispa/public_html/wp-content/plugins/ilab-media-tools/vendor/illuminate/filesystem/Filesystem.php on line 122

    Warning: file_put_contents(https://www.cloudlinux.com/hardenedphp-wp/mcloud-views/4694eb5409a6d0e4161187f881984b83641a88e7.php) failed to open stream: no suitable wrapper could be found in /home/thisispa/public_html/wp-content/plugins/ilab-media-tools/vendor/illuminate/filesystem/Filesystem.php on line 122

    Warning: include(): https:// wrapper is disabled in the server configuration by allow_url_fopen=0 in /home/thisispa/public_html/wp-content/plugins/ilab-media-tools/vendor/illuminate/view/Engines/PhpEngine.php on line 42

    Warning: include(https://www.cloudlinux.com/hardenedphp-wp/mcloud-views/4694eb5409a6d0e4161187f881984b83641a88e7.php) failed to open stream: no suitable wrapper could be found in /home/thisispa/public_html/wp-content/plugins/ilab-media-tools/vendor/illuminate/view/Engines/PhpEngine.php on line 42

    Warning: include(): Failed opening 'https://www.cloudlinux.com/hardenedphp-wp/mcloud-views/4694eb5409a6d0e4161187f881984b83641a88e7.php' for inclusion (include_path='.:/opt/cpanel/ea-php70/root/usr/share/pear') in /home/thisispa/public_html/wp-content/plugins/ilab-media-tools/vendor/illuminate/view/Engines/PhpEngine.php on line 42

    Warning: file_put_contents(): https:// wrapper is disabled in the server configuration by allow_url_fopen=0 in /home/thisispa/public_html/wp-content/plugins/ilab-media-tools/vendor/illuminate/filesystem/Filesystem.php on line 122

    Warning: file_put_contents(https://www.cloudlinux.com/hardenedphp-wp/mcloud-views/4694eb5409a6d0e4161187f881984b83641a88e7.php) failed to open stream: no suitable wrapper could be found in /home/thisispa/public_html/wp-content/plugins/ilab-media-tools/vendor/illuminate/filesystem/Filesystem.php on line 122

    Warning: include(): https:// wrapper is disabled in the server configuration by allow_url_fopen=0 in /home/thisispa/public_html/wp-content/plugins/ilab-media-tools/vendor/illuminate/view/Engines/PhpEngine.php on line 42

    Warning: include(https://www.cloudlinux.com/hardenedphp-wp/mcloud-views/4694eb5409a6d0e4161187f881984b83641a88e7.php) failed to open stream: no suitable wrapper could be found in /home/thisispa/public_html/wp-content/plugins/ilab-media-tools/vendor/illuminate/view/Engines/PhpEngine.php on line 42

    Warning: include(): Failed opening 'https://www.cloudlinux.com/hardenedphp-wp/mcloud-views/4694eb5409a6d0e4161187f881984b83641a88e7.php' for inclusion (include_path='.:/opt/cpanel/ea-php70/root/usr/share/pear') in /home/thisispa/public_html/wp-content/plugins/ilab-media-tools/vendor/illuminate/view/Engines/PhpEngine.php on line 42

    Warning: file_put_contents(): https:// wrapper is disabled in the server configuration by allow_url_fopen=0 in /home/thisispa/public_html/wp-content/plugins/ilab-media-tools/vendor/illuminate/filesystem/Filesystem.php on line 122

    Warning: file_put_contents(https://www.cloudlinux.com/hardenedphp-wp/mcloud-views/3778598cb482a58b77660d928179fd03d2a20848.php) failed to open stream: no suitable wrapper could be found in /home/thisispa/public_html/wp-content/plugins/ilab-media-tools/vendor/illuminate/filesystem/Filesystem.php on line 122

    Warning: include(): https:// wrapper is disabled in the server configuration by allow_url_fopen=0 in /home/thisispa/public_html/wp-content/plugins/ilab-media-tools/vendor/illuminate/view/Engines/PhpEngine.php on line 42

    Warning: include(https://www.cloudlinux.com/hardenedphp-wp/mcloud-views/3778598cb482a58b77660d928179fd03d2a20848.php) failed to open stream: no suitable wrapper could be found in /home/thisispa/public_html/wp-content/plugins/ilab-media-tools/vendor/illuminate/view/Engines/PhpEngine.php on line 42

    Warning: include(): Failed opening 'https://www.cloudlinux.com/hardenedphp-wp/mcloud-views/3778598cb482a58b77660d928179fd03d2a20848.php' for inclusion (include_path='.:/opt/cpanel/ea-php70/root/usr/share/pear') in /home/thisispa/public_html/wp-content/plugins/ilab-media-tools/vendor/illuminate/view/Engines/PhpEngine.php on line 42



  • @thisispa Which version of the plugin are you using?



  • @thisispa Also who is your hosting provider?



  • Hosting is on Dragify - and the plugin version is 3.1.1





  • @jong still getting the same errors - looks like now there are a lot of pear exceptions as well. I think I'm going to pull the site and transfer it over to my business host, which is using the plugin without issue for two websites now.

    New Errors:

    Warning: file_put_contents(): https:// wrapper is disabled in the server configuration by allow_url_fopen=0 in /home/thisispa/public_html/wp-content/plugins/ilab-media-tools/vendor/illuminate/filesystem/Filesystem.php on line 122

    Warning: file_put_contents(https://www.cloudlinux.com/hardenedphp-wp/mcloud-views/4694eb5409a6d0e4161187f881984b83641a88e7.php😞 failed to open stream: no suitable wrapper could be found in /home/thisispa/public_html/wp-content/plugins/ilab-media-tools/vendor/illuminate/filesystem/Filesystem.php on line 122

    Warning: include(): https:// wrapper is disabled in the server configuration by allow_url_fopen=0 in /home/thisispa/public_html/wp-content/plugins/ilab-media-tools/vendor/illuminate/view/Engines/PhpEngine.php on line 42

    Warning: include(https://www.cloudlinux.com/hardenedphp-wp/mcloud-views/4694eb5409a6d0e4161187f881984b83641a88e7.php😞 failed to open stream: no suitable wrapper could be found in /home/thisispa/public_html/wp-content/plugins/ilab-media-tools/vendor/illuminate/view/Engines/PhpEngine.php on line 42

    Warning: include(): Failed opening 'https://www.cloudlinux.com/hardenedphp-wp/mcloud-views/4694eb5409a6d0e4161187f881984b83641a88e7.php' for inclusion (include_path='/home/thisispa/public_html/wp-content/plugins/backwpup/vendor/pear/archive_tar:/home/thisispa/public_html/wp-content/plugins/backwpup/vendor/pear/console_getopt:/home/thisispa/public_html/wp-content/plugins/backwpup/vendor/pear/http_request2:/home/thisispa/public_html/wp-content/plugins/backwpup/vendor/pear/mail_mime:/home/thisispa/public_html/wp-content/plugins/backwpup/vendor/pear/mail_mime-decode:/home/thisispa/public_html/wp-content/plugins/backwpup/vendor/pear/net_url2:/home/thisispa/public_html/wp-content/plugins/backwpup/vendor/pear/pear-core-minimal/src:/home/thisispa/public_html/wp-content/plugins/backwpup/vendor/pear/pear_exception:.:/opt/cpanel/ea-php70/root/usr/share/pear') in /home/thisispa/public_html/wp-content/plugins/ilab-media-tools/vendor/illuminate/view/Engines/PhpEngine.php on line 42

    Warning: file_put_contents(): https:// wrapper is disabled in the server configuration by allow_url_fopen=0 in /home/thisispa/public_html/wp-content/plugins/ilab-media-tools/vendor/illuminate/filesystem/Filesystem.php on line 122

    Warning: file_put_contents(https://www.cloudlinux.com/hardenedphp-wp/mcloud-views/4694eb5409a6d0e4161187f881984b83641a88e7.php😞 failed to open stream: no suitable wrapper could be found in /home/thisispa/public_html/wp-content/plugins/ilab-media-tools/vendor/illuminate/filesystem/Filesystem.php on line 122

    Warning: include(): https:// wrapper is disabled in the server configuration by allow_url_fopen=0 in /home/thisispa/public_html/wp-content/plugins/ilab-media-tools/vendor/illuminate/view/Engines/PhpEngine.php on line 42

    Warning: include(https://www.cloudlinux.com/hardenedphp-wp/mcloud-views/4694eb5409a6d0e4161187f881984b83641a88e7.php😞 failed to open stream: no suitable wrapper could be found in /home/thisispa/public_html/wp-content/plugins/ilab-media-tools/vendor/illuminate/view/Engines/PhpEngine.php on line 42

    Warning: include(): Failed opening 'https://www.cloudlinux.com/hardenedphp-wp/mcloud-views/4694eb5409a6d0e4161187f881984b83641a88e7.php' for inclusion (include_path='/home/thisispa/public_html/wp-content/plugins/backwpup/vendor/pear/archive_tar:/home/thisispa/public_html/wp-content/plugins/backwpup/vendor/pear/console_getopt:/home/thisispa/public_html/wp-content/plugins/backwpup/vendor/pear/http_request2:/home/thisispa/public_html/wp-content/plugins/backwpup/vendor/pear/mail_mime:/home/thisispa/public_html/wp-content/plugins/backwpup/vendor/pear/mail_mime-decode:/home/thisispa/public_html/wp-content/plugins/backwpup/vendor/pear/net_url2:/home/thisispa/public_html/wp-content/plugins/backwpup/vendor/pear/pear-core-minimal/src:/home/thisispa/public_html/wp-content/plugins/backwpup/vendor/pear/pear_exception:.:/opt/cpanel/ea-php70/root/usr/share/pear') in /home/thisispa/public_html/wp-content/plugins/ilab-media-tools/vendor/illuminate/view/Engines/PhpEngine.php on line 42



  • @jong transferred the site to our other hosting account (IONOS) and the plugin is working perfectly now. Just for your reference I did try modifying the php.ini on the other account (Dragify), setting allow_url_fopen=1 to try and resolve the issue, but to no avail. Maybe there is a server conflict with Dragify? Thanks for your help either way.


Log in to reply