Announcement Regarding Support

Hello everyone, Charles here. Please read my post on changes to Media Cloud support and updates regarding Media Cloud in general.


Does Media Cloud require any specific IPs?

  • I installed Media Cloud and the troubleshooter ticks everything except for the bulk upload feature.
    I've tried uploading some new images to my Wordpress site and they uploaded correctly.
    I've been talking to my site host and they want to know if the plugin is trying to connect to, or listening for a response from any specific external IP Addresses?
    THey say it sounds like it could be a firewall block somewhere, as it looks like the plugin is waiting for a response that it never gets and therefore times out.
    They say their servers don't block things such as AJAX requests.

  • No it doesn't require a specific IP.

    Usually when the background tasks don't work it's because of one of the following:

    • cURL is misconfigured on the system
    • The server won't allow connections from localhost
    • SSL is actually handled at a proxy server somewhere up the level causing SSL verification to fail
    • DNS resolution on the server is messed up somehow

    Did you try going into Batch Processing settings and:

    • Setting Connection Timeout and Timeout to 15
    • Turn off Verify SSL by setting it to "no"
    • Turn on Skip DNS

    If all else fails there, you can turn off background processing and still use the Migrate to Cloud tool, you just have to leave the browser window open and if you close it, you'll have to run it again to continue.

    I usually recommend that people use the command line tool instead as it's more robust and allows you to do it in smaller batches. I talk about that here:

  • Also, those are just guesses why it doesn't work. I've never actually been able to replicate the issue.

    What hosting provider are you using?

  • @jong

  • @jong said in Does Media Cloud require any specific IPs?:

    Turn off Verify SSL by setting it to "no"

    It might have something to do with the REST API?

  • @jong said in Does Media Cloud require any specific IPs?:

    Did you try going into Batch Processing settings and:

    Setting Connection Timeout and Timeout to 15
    Turn off Verify SSL by setting it to "no"
    Turn on Skip DNS

    I don't see these settings????

  • In settings, towards the bottom:

    Monosnap 2019-07-21 08-11-01.png

  • Odd, but I'm not seeing this menu option anymore. It was there before.
    My web host has been really helpful but they are unable to get the plugin working wirh Amazon S3.
    I had to disable the plugin because although it successfully uploaded the images from a new post, I don't think they could be retrieved when I tried to preview that post.
    When I run the Troubleshooter it brings down the website witha 503 error when it gets to the batch process check.
    I'm out of my depth and I don't know how to proceed?

  • Contact me @ [email protected]

  • Are you able to confirm what IP ranges Media Cloud operates on?

  • @Revhead

    Yeah, I've been testing it and background processing won't work on your WordPress install. I honestly don't know why. But it's also not limited to Media Cloud. If you run Site Health test in the Tools menu:

    Site Health Info ‹ — WordPress 2019-07-22 10-16-09.png

    After the test runs, you'll see:

    Screenshot of Safari (7-22-19, 10-18-24 AM).png

    So that tells us your server is not configured correctly or you hosting provider has some weird setup that doesn't allow loopback.

    You can still do the Migrate to Storage however. You will just need to leave that browser window open until it is finished.

  • @jong
    No there's more to it than that.
    While any new stuff I upload works, WordPress will not display the images.
    I have to turn off Media Cloud, delete the images from WordPress and re-add them to get them to display.
    What about the IP ranges that Media Cloud uses, what are they?

  • @Revhead

    There's no IP ranges, I don't even know what that means.

    Where are you displaying the images that they are broken? In a post? In some third party image gallery plugin? Do you have URLs where there broken images that I can see?

  • Displaying the images in a post gallery. It just shows placeholders. Can't show you because I corrected them.

  • @Revhead

    How do you make the gallery?

  • @Revhead

    Can you make an unpublished post with a gallery with broken images so I can see the preview?

  • @jong

    Good news. Some anyway.
    Single photos are now working. I uploaded images with the box ticked to delete them from server. All looks good.
    Galleries. My theme BfastMag Pro has a plugin called Tiled Galleries without Jetpck. I diabled this and the gallery (using the same 9 x single pix that I uploaded previously) now seem to work.
    Both single and gallery photos preview okay.
    Only thing not working now is batch processing.
    I should mention that instead of your bucket policy recommendation, I am using “AmazonS3FullAccess”. Don't know if there is any difference?

  • @Revhead

    Yeah a lot of gallery plugins try to do things outside of the WordPress(tm) way of doing things, I'm not sure why.

    Email me when you are ready to do batch processing and I'll troubleshoot it again.

    As for the AmazonS3FullAccess policy, that's fine but it's more insecure.

  • @Revhead

    Version 3.1.0 was released that should fix your issues with migrating to the cloud.

  • I can upload images manually using the Migrate tool, but Troubleshooter still gives the batch error even with the new version.
    Have to work out how to install WP-CLI so I can upload them more than 20 at a time.

Log in to reply