Upgrade to 3.0 Vendor Files missing?



  • Hi,

    Thanks for a great release! Been perusing the code and it looks great. I tried upgrading a local plugin from v2 to v3 via the WordPress plugin upgrader, and after updating, it kicked off a fatal error:

    Fatal error: Uncaught Error: Class 'ILAB\MediaCloud\Tools\ToolsManager' not found in /plugins/ilab-media-tools/ilab-media-tools.php:152
    

    It looks like the autoloader.php and some vendor files were just missing, so after doing composer install from the /plugins/ilab-media-tools directory, everything worked correctly.

    Hope this is all that's needed for a quick update to the WP Plugin Directory!

    Cheers,
    Jeremy



  • Yes pushing the fix to WordPress right now.


Log in to reply