Notice: Undefined index: x-amz-bucket-region in /home/customer/www/staging5.vitfarma.es/public_html/wp-content/plugins/ilab-media-tools/vendor/ilab/ilab-aws-media-cloud-sdk/src/S3/S3ClientTrait.php on line 219



  • Hello, since the last update this error is appearing:

    Notice: Undefined index: x-amz-bucket-region in /home/customer/www/staging5.vitfarma.es/public_html/wp-content/plugins/ilab-media-tools/vendor/ilab/ilab-aws-media- cloud-sdk / src / S3 / S3ClientTrait.php on line 219

    Anyone know how to fix it?

    Thank you!



  • @Benja-Vitalfarma

    I'm assuming you are not using S3, which means whatever your using is really only 90% compatible with S3. They aren't returning an HTTP header that the AWS SDK is expecting. There's not much I can do about that as the SDK comes from Amazon. Even though it says ilab-aws-media-cloud-sdk, we just wrap the SDK in a namespace to avoid collision with other WordPress plugins.

    Your best bet is to turn off reporting of Notice messages. If this is a production site, you should set display_errors to off in php.ini:

    display_errors: off
    

    There's no good reason to display errors to your end users on a live site. You should, instead, make sure you have PHP logging setup so you can keep an eye on things.


Log in to reply