Long response website with the plugin enabled



  • Yesterday around 12:00 UTC, the website began to respond to a request for a long time. You can’t even enter the admin console, error 504 appears. If you disable the Media Cloud plugin, everything starts to work well.

    Screenshot_1.png



  • Enabled WP_Debug in log

    PHP Notice: Undefined index: x-amz-bucket-region in ../wp-content/plugins/ilab-media-tools/vendor/ilab/ilab-aws-media-cloud-sdk/src/S3/S3ClientTrait.php on line 219

    Hoster log

    (70007)The timeout specified has expired: AH01075: Error dispatching request to :, referer: ../wp-admin/plugins.php?charsout=233&plugin=ilab-media-tools%2Filab-media-tools.php&plugin_status=all&paged=1&s

    2688590#0: *5193179 upstream timed out (110: Connection timed out) while reading response header from upstream



  • How to enable Media Cloud Debugging if it is not possible to log into the administrator console, constantly error 504?



  • Having received error 504 for a long time, I was still able to open the settings and enable debugging.
    Screenshot_2.png

    When Cloud Storage is disabled, the site does not work. It only helps to completely disable the plugin.

    How to find out now what is the problem? Admin console and website still generate error 504.



  • AH01071: Got error 'PHP message: [2019-11-29 09:44:00] ilab-media-tool.INFO: [3098025] Could not get region from server. [] []\nPHP message: [2019-11-29 09:44:00] ilab-media-tool.INFO: [3098025] Could not create regular client, creating multi-region client instead. [] []\n'

    AH01071: Got error 'PHP message: [2019-11-29 09:50:25] ilab-media-tool.INFO: [3098116] Undefined index: x-amz-bucket-region {"file":"/wp-content/plugins/ilab-media-tools/vendor/ilab/ilab-aws-media-cloud-sdk/src/S3/S3ClientTrait.php","line":219} []\n',

    AH01071: Got error 'PHP message: [2019-11-29 10:09:49] ilab-media-tool.INFO: [3591557] Could not get region from server. [] []\nPHP message: [2019-11-29 10:09:49] ilab-media-tool.INFO: [3591557] Could not create regular client, creating multi-region client instead. [] []\nPHP message: [2019-11-29 10:09:50] ilab-media-tool.INFO: [3591557] Undefined index: x-amz-bucket-region {"file":".../wp-content/plugins/ilab-media-tools/vendor/ilab/ilab-aws-media-cloud-sdk/src/S3/S3ClientTrait.php","line":219} []\n', referer: .../wp-admin/

    (70007)The timeout specified has expired: AH01075: Error dispatching request to :, referer: .../wp-admin/admin.php?page=media-tools-debug-log



  • @aleshij

    This should be resolved in the latest version, let me know if it isn't.

    Once you re-enable Media Cloud, go into the Task Manager section and clear out any pending tasks and then clear out the history.


Log in to reply