Unable to dispatch background task — no matter what



  • I get the warning 'Your WordPress server configuration does not support background processing' when I run the system compatibility test. It doesn't matter if I go to batch processing tools and up the timeouts to 10 seconds, change the client, enable or disable anything on that screen. It still fails.

    I saw some recommendations in the wordpress support forums to disable background processing in the media cloud settings, but I don't see this setting anywhere.

    I did try disabling wp-cron in wp-config.php, but it didn't help.



  • @Threex5

    Your server is misconfigured or badly configured or poorly configured. There's not much you can do about that.

    You can get background tasks to run though, it'll just be done more slowly.

    Make sure you wp-cron is setup like they recommend here:

    https://kinsta.com/knowledgebase/disable-wp-cron/

    The basic gist is that wp-cron be disabled, but still triggered from your server's system crontab.

    The rest you can leave alone and things should work, although much much much slower.



  • Thanks for the reply. I'm controlling my own Ubuntu VPS that I installed from scratch, so there should be a lot I can do about a misconfigured server. I'm not sure what would be misconfigured, though. So far, I've done everything Media Cloud recommends: I upgraded php to 7.3, I updated all my packages, I switched my server api to php-fpm, I increased the file upload size and timeout times in php.ini.

    I also disabled wp-cron and added an hourly cron job in crontab. So I'm not sure what else I need to do here, or how to troubleshoot. I had debugging on for a while, but I wasn't seeing anything useful in it.


Log in to reply