504 Gateway error a few moment after activated the plugin



  • Hello everyone!

    My boss bought the premium version of the Media Cloud plugin and I installed it on my local website. Everytime I activate the plugin, I got a 504 Gateway error a few seconds later. I discovered that a loop of requests (all same) is the cause of that error. Here is the request:

    appserver_nginx_1  | 172.19.0.8 - - [05/Nov/2019:19:06:05 +0000] "POST /cms/wp-admin/admin-ajax.php?action=mcloud_run_task&taskId=1&taskType=test-task&token=__mcloud_token_85dc1c7f0197f8&tokenVal=85dc1c7f019802&nonce=40753e3094 HTTP/1.1" 499 0 "https://website.lndo.site/cms/wp-admin/admin-ajax.php?action=mcloud_run_task&taskId=1&taskType=test-task&token=__mcloud_token_85dc1c7f0197f8&tokenVal=85dc1c7f019802&nonce=40753e3094" "WordPress/5.2.4; https://website.lndo.site"
    

    We already used the free version before, but it's our first time with the paid one.

    FYI I'm using Docker and Lando for my local websites. The version of the plugin is 3.2.3.



  • @kevin

    When you activate the plugin or when you run the system check?



  • Actually, I'd already setup the plugin and I got the error afterwards. Since that moment, I had disable the plugin but everytime I reactivate it, I got the same error. Since my last message, I tried to disable Dynamic Images feature but nothing changed



  • @kevin

    Well that particular URL is triggered when running a test task which is only run from the system check.

    If you have database access, delete all the rows from wp_mcloud_task, wp_mcloud_task_data, wp_mcloud_task_schedule tables



  • @kevin

    Also, are you running xdebug on your local site by chance?



  • Thanks!

    Since I've deleted the rows, I don't have the problem anymore.

    And yes, I'm running xdebug on my local site


Log in to reply