WAMP configuration- server clock issue



  • Hello,
    I am using WAMP to work on my site. I bought the premium version of the plugin. I configured my S3 bucket and users as it's shown in the tutorial. I got the next errors after the system check, of what the second is critical, the rest is just at warning level.

    where should I set the server clock?

    SYSTEM COMPATIBILITY

    • Various aspects of your system that might have compatibility issues with Media Cloud

    • Your server's system clock is wrong by over 130 years 2 months 1 week 3 days 11 hours 19 minutes 3 seconds. This will cause errors with cloud storage services. You may need to contact your hosting provider to correct the situation.

    • Your PHP version (7.2.18) is compatible but should be upgraded to 7.x as soon as possible. The version you are using is no longer updated by PHP maintainers.

    • You are not using PHP-FPM. PHP-FPM can seriously improve the speed and responsiveness of your site. Contact your hosting provider for more information.

    • The max_execution_time is set to a good value (120).

    • WordPress Cron is enabled. For better performance, consider disabling WordPress Cron and running it from the system crontab. Read more about the best way of setting up WordPress Cron.

    VALIDATE STORAGE SETTINGS

    • There was an error or errors trying to connect to the storage provider.


  • @Szilárd-Dénes

    Dump WAMP for Local by FlyWheel. You can thank me later.

    I very much doubt Media Cloud will run on Windows without any issues.



  • Thanks for the quick answer!
    So there is no chance to run on windows?
    Will be okay after using on my normal server?



  • @jong

    I've tried using Local by Flywheel, I couldn't fix the issue below.

    local by flywheel.jpg



  • @Szilárd-Dénes

    Yes, it'll be fine if your server is running linux.

    It should run on Windows, but I can't guarantee it. I haven't used Windows since the late 90's. And I'm a pretty ardent supporter of 12 factor:

    https://12factor.net

    The main tenet is that your dev environment should be as close to your deployment environment as possible.





  • @jong
    Yes, I tried every solution. I gave full access to the host file, I gave all the possible exclusions in the Windows Defender and my Sophos antivirus, but no change.


Log in to reply